At the moment our users may experience some minor issues with connection to FXCM broker accounts.

Identified
We will fix it soon.
Wed, 18 Jan 2017 16:40:00 GMT
Resolved
The problem has been fixed.
Wed, 18 Jan 2017 16:56:00 GMT
Current Status