At the moment our users may experience some minor issues with forex data from IDC (the ICE).

Identified
We will fix it soon.
Thu, 16 Feb 2017 01:00:00 GMT
Resolved
The problem has been fixed.
Thu, 16 Feb 2017 04:50:00 GMT
Current Status