Chart loading issue

Investigating
At the moment our users may experience some issues with loading charts. We will fix it soon.
Wed, 15 Mar 2017 13:33:20 GMT
Identified
The problem is solved. Some charts can be still loading data. All charts will be loaded within 3-4 minutes.
Wed, 15 Mar 2017 14:00:31 GMT
Identified
Charts are operational. Data for screener will be restored asap.
Wed, 15 Mar 2017 14:14:01 GMT
Resolved
The problem has been fixed.
Wed, 15 Mar 2017 14:21:47 GMT
Current Status