News feed is down.

Investigating
We are already looking into the issue. Thank you for understanding!
Fri, 12 May 2017 14:17:58 GMT
Identified
The problem will be fixed within a couple of hours.
Fri, 12 May 2017 15:36:10 GMT
Resolved
The problem is solved.
Fri, 12 May 2017 16:10:34 GMT
Current Status