An issue with performance

Investigating
Some of our users might be experiencing some issues with the performance of the software. It can be general website loading speed or an issue with real-time data. Our engineers are looking into the case to fix the problem asap.
Sat, 02 Dec 2017 10:14:40 GMT
Resolved
The issue has been solved.
Mon, 04 Dec 2017 16:38:21 GMT
Current Status