KRAKEN: data feed degraded

Investigating
We are looking into the case.
Wed, 20 Dec 2017 08:55:10 GMT
Resolved
The data feed is operational.
Thu, 21 Dec 2017 16:03:51 GMT
Current Status