AN ISSUE WITH PERFORMANCE

Investigating
Some of our users might be experiencing some issues with the performance of the software. Our engineers are looking into the case to fix the problem asap.
Fri, 22 Dec 2017 15:26:53 GMT
Resolved
The problem has been solved.
Fri, 22 Dec 2017 15:52:04 GMT
Current Status