An issue with alerts creating.

Investigating
Some users may experience problems with creating alerts. We are looking into the case.
Sat, 23 Dec 2017 10:30:04 GMT
Identified
Maintenance - Some users might see short-term issues with alerts.
Sat, 23 Dec 2017 11:10:05 GMT
Resolved
Alerts fixed.
Sat, 23 Dec 2017 11:36:11 GMT
Current Status