An issue with performance

Identified
Some of our users might be experiencing some issues with the website loading speed. Our engineers are working on mitigating the problem.
Tue, 09 Jan 2018 08:02:29 GMT
Resolved
The problem has been solved.
Tue, 09 Jan 2018 08:36:22 GMT
Current Status