Charts loading is delayed

Investigating
Some users might experience an issue with charts loading slowly. We are working to solve it asap.
Wed, 14 Feb 2018 15:13:10 GMT
Resolved
Charts are operational.
Wed, 14 Feb 2018 16:00:26 GMT
Current Status