ALERTS: service degraded.

Identified
Some users may experience issues with alerts. Our team is working to fix the issue asap.
Thu, 05 Apr 2018 08:55:56 GMT
Resolved
All alerts are operational.
Thu, 05 Apr 2018 12:21:12 GMT
Current Status