SUPPORT: not available

Identified
The ticket system our support is using to solve users' issues is not available temporarily. Our team is bringing it back online with a high priority.
Thu, 05 Apr 2018 12:17:59 GMT
Resolved
The support team is helping users again! :-)
Thu, 05 Apr 2018 13:21:36 GMT
Current Status