CEX.IO Downtime

Identified
Maintenance on the exchange side - https://cex.io/
Fri, 20 Apr 2018 12:53:46 GMT
Resolved
Resolved
Tue, 24 Apr 2018 14:49:45 GMT
Current Status