Issues with trading

Investigating
Some users may have problems with trading. We are investigating the case.
Fri, 31 Aug 2018 09:41:46 GMT
Resolved
Problem fixed.
Fri, 31 Aug 2018 12:39:56 GMT
Current Status