No real-time data by IDC.

Identified
We've identified problems with our data. Our techs are working on fixing it.
Mon, 08 Oct 2018 14:27:37 GMT
Resolved
The problem is fixed.
Mon, 08 Oct 2018 14:56:32 GMT
Current Status