CEXIO - Partial outage

Identified
Maintenance.
Tue, 09 Oct 2018 15:37:07 GMT
Resolved
Resolved.
Tue, 09 Oct 2018 15:48:21 GMT
Current Status