NYMEX:CLZ2018 - no real-time data.

Identified
We've identified the issue and working on fixing it.
Fri, 19 Oct 2018 13:50:06 GMT
Resolved
The problem solved successfully.
Fri, 19 Oct 2018 15:10:51 GMT
Current Status