Data loading problems

Identified
Some users may have problems with data loading on charts.
Fri, 09 Nov 2018 16:01:40 GMT
Resolved
Problems solved.
Fri, 09 Nov 2018 17:37:01 GMT
Current Status