Problems with opening support tickets

Investigating
Some customers can have problems with opening support tickets. We are investigating the case.
Mon, 12 Nov 2018 15:57:29 GMT
Resolved
Issue fixed.
Tue, 13 Nov 2018 10:37:36 GMT
Current Status