Data loading problems

Investigating
Some users may have problems with data loading on charts.
Wed, 14 Nov 2018 14:02:14 GMT
Resolved
Fixed.
Wed, 14 Nov 2018 15:06:23 GMT
Current Status