NDX charts are not updating

Investigating
We're investigating the issue.
Thu, 10 Jan 2019 15:23:33 GMT
Resolved
The issue has been fixed. We apologize for the inconvenience.
Thu, 10 Jan 2019 16:50:34 GMT
Current Status