FXCM data issues

Investigating
Some users may experience incorrect data on daily FXCM charts.
Fri, 15 Feb 2019 13:58:08 GMT
Resolved
The problem has been fixed.
Tue, 19 Feb 2019 16:23:32 GMT
Current Status