Screener alerts under maintenance

Identified
Screener alerts under maintenance till 21.02.19
Thu, 21 Feb 2019 07:55:27 GMT
Resolved
Screener alerts are operational now
Thu, 21 Feb 2019 12:00:03 GMT
Current Status