Screener alerts under maintenance

Identified
Screener alerts are temporarily out of service
Thu, 21 Feb 2019 15:04:55 GMT
Resolved
Screener alerts are operational
Mon, 25 Feb 2019 10:40:56 GMT
Current Status