Slow loading data

Identified
We've identified the problem when charts load very slowly.
Tue, 28 May 2019 14:12:40 GMT
Resolved
Problem solved successfully.
Tue, 28 May 2019 14:30:52 GMT
Current Status