TVC: data problems

Investigating
We are working on the issue.
Wed, 12 Jun 2019 07:50:25 GMT
Resolved
The issue has been fixed.
Thu, 13 Jun 2019 11:40:42 GMT
Current Status