CME data partially unavailable

Identified
Our techs are working on fixing the problem.
Tue, 18 Jun 2019 15:10:17 GMT
Resolved
The problem is fixed.
Tue, 18 Jun 2019 17:23:29 GMT
Current Status