Slow loading data

Identified
We've identified the problem when charts load very slowly.
Mon, 30 Sep 2019 13:18:32 GMT
Resolved
Problem solved
Mon, 30 Sep 2019 14:39:30 GMT
Current Status