Scheduled maintenance for watchlists

Identified
Today (December 14), from 10:30 to 11:30 UTC, we're planning a scheduled maintenance for watchlists to make them faster. During this time, watchlists will be unavailable.
Sat, 14 Dec 2019 08:20:16 GMT
Resolved
Maintenance has been completed
Sat, 14 Dec 2019 16:40:59 GMT
Current Status