Scheduled maintenance for watchlists

Investigating
This Saturday, January 18, we will be performing maintenance on watchlists to improve their performance. For 30 minutes between the hours 11:00 and 13:00 UTC, all watchlists will be unavailable.
Sat, 18 Jan 2020 11:10:29 GMT
Resolved
Maintenance has been completed
Sat, 18 Jan 2020 15:17:59 GMT
Current Status