Tadawul - Saudi Stock Exchange data problems

Identified
The issue was caused by our data provider. We are working closely with them to resolve the problem.
Tue, 24 Mar 2020 07:44:08 GMT
Resolved
The problem is resolved.
Tue, 24 Mar 2020 12:20:27 GMT
Current Status