Charts populating slowly

Investigating
Data on some charts might be loading slow. We are working on the issue.
Wed, 10 Jan 2018 11:51:41 GMT
Resolved
The issue has been fixed.
Wed, 10 Jan 2018 12:15:23 GMT
Current Status