Some users may experience issues with BME and TVC charts

Investigating
We're in touch with our data provider regard this issue.
Mon, 17 Dec 2018 09:39:14 GMT
Identified
BME real-time was resumed.
Mon, 17 Dec 2018 15:02:04 GMT
Resolved
The issue has been fixed. Please, reload the page.
Mon, 24 Dec 2018 10:23:57 GMT
Current Status