OMX data issue

Identified
The tech team is working on the problem.
Mon, 17 Jun 2019 07:44:36 GMT
Resolved
The issue has been fixed.
Mon, 17 Jun 2019 11:18:00 GMT
Current Status