FX_IDC: and TVC: data problems

Identified
We've identified the issue and areworking on the fix.
Thu, 15 Aug 2019 21:34:10 GMT
Resolved
The issue has been fixed.
Fri, 16 Aug 2019 06:53:50 GMT
Current Status