Charts are not loading

Identified
Some users may have problems loading their charts. We are working on a fix.
Fri, 03 Apr 2020 13:49:17 GMT
Resolved
Successfully fixed.
Fri, 03 Apr 2020 14:51:27 GMT
Current Status