Slow loading

Identified
Some users may experience issues with the data loading. The tech team is working on the fix.
Tue, 11 Aug 2020 13:55:14 GMT
Resolved
The issue has been fixed.
Tue, 11 Aug 2020 14:19:41 GMT
Current Status