MOEX data is not updating

Identified
The issue is on the vendor's end. The tech team is working with them on the fix.
Wed, 16 Sep 2020 20:20:35 GMT
Resolved
The issue has been fixed.
Thu, 17 Sep 2020 08:18:39 GMT
Current Status