At the moment our users may experience some minor issues with TSE data

Investigating
We're investigating TSE daily charts.
Fri, 02 Oct 2020 00:46:10 GMT
Resolved
The issue has been fixed.
Fri, 02 Oct 2020 07:59:17 GMT
Current Status