OSE data feed is not updating

Investigating
We are investigating the issue.
Wed, 23 Dec 2020 01:54:54 GMT
Resolved
The issue has been resolved
Wed, 23 Dec 2020 03:06:56 GMT
Current Status