Slow loading

Identified
Some users may experience slow loading of the platform. We're on the fix.
Wed, 27 Jan 2021 15:20:41 GMT
Resolved
The issue has been resolved.
Wed, 27 Jan 2021 15:44:09 GMT
Current Status