Slow loading

Investigating
Some users may experience slow loading of the platform. The tech team is on the issue.
Mon, 22 Feb 2021 14:40:06 GMT
Resolved
The issue has been fixed.
Mon, 22 Feb 2021 15:20:14 GMT
Current Status