SMS delivery issue

Identified
SMS service is currently unavailable. The provider is on the fix.
Fri, 26 Feb 2021 13:33:11 GMT
Resolved
The issue has been resolved.
Mon, 01 Mar 2021 07:53:41 GMT
Current Status