FXCM charts are not updating

Investigating
We're investigating the issue.
Mon, 19 Jul 2021 00:18:35 GMT
Resolved
The issue has been resolved.
Mon, 19 Jul 2021 04:42:44 GMT
Current Status