Slow loading

Identified
Some users can experience the slow loading of the platform. The tech team is on the fix.
Tue, 19 Oct 2021 05:07:15 GMT
Resolved
The issue has been fixed.
Tue, 19 Oct 2021 08:03:18 GMT
Current Status