Slow loading

Investigating
Some users may experience slow loading of the plarform. Our tech team is on the issue.
Mon, 03 Jan 2022 14:57:58 GMT
Resolved
The issue has been resolved.
Mon, 03 Jan 2022 19:24:32 GMT
Current Status