Slow loading

Investigating
Some users may experience slow loading of the platform. The tech team is on the issue.
Mon, 10 Jan 2022 14:58:35 GMT
Resolved
The issue has been resolved.
Mon, 10 Jan 2022 15:51:27 GMT
Current Status