Some data feed is stopped updating

Investigating
Our engineers are investigating the issue.
Tue, 21 Jun 2022 07:14:14 GMT
Resolved
Data feeds are working now
Tue, 21 Jun 2022 09:44:04 GMT
Current Status