IDX data issue

Investigating
The tech team is working on the issue.
Mon, 03 Oct 2022 02:26:47 GMT
Resolved
Data feeds are working now
Mon, 03 Oct 2022 05:07:18 GMT
Current Status